
 ErgoSoft ARCHON

Help Contents
Choose one of the following topics to learn about using ErgoSoft ARCHON. To learn how to 
use Help, press F1 or choose Using Help from the Help menu.

Basics
Menus
Procedures
Index of Commands



 Command Menus

Commands may be entered using menus, using the keyboard or by dragging icons and 
dropping them on the appropriate tool symbol.    To specify which objects will be treated by a
command you must select the appropriate icon before giving the command.    An alternate 
method to select icons and activate tools is to use the keyboard

File Menu Commands
Edit Menu Commands
Objects Menu Commands
Retrieval Menu Commands
Options Menu Commands
Help Menu Commands



 Procedures

How to select objects and issue a command
How to get information into the archive
How to find information in the archive
How to modify information in the archive
How to get information out of the archive
How to register for ARCHON usage



 Command Index

About Command
Commands to apply methods on objects
Copy Command
Delete Command
Define predefined query Command
Description Command
Exit Command
Export Command
Function bar option Command
Help command Command
Help index Command
Help on help Command
Help procedures Command
Hide Command
Icon option Command
Import Command
Information Command
Methods option Command
Modify predefined query Command
Query Command
Paste Command
Rearrange Command
Register Command
Reorganize Command
Return Command
Select predefined query Command
Show Command
Snap Command



 File Menu

File Menu commands are concerned with internally defined operations on archive-data. 
These operations include adding, extracting and removing archive-data.    Operations defined
by the user are available from the Objects menu.

Get Information about an Object
Import Data into the Archive
Export Data from the Archive
Change Name and Description of an object
Exit ARCHON



 Edit Menu

Copy an object to the Clipboard
Paste data from the clipboard
Delete an object
Return an icon
Hide an icon
Show hidden icons



 Objects Menu

Objects Menu commands are used to apply user-configurable methods to an object in the 
archive. All methods configured in the profile are presented in the Objects menu.



 Retrieval Menu

Retrieval Menu commands allow searching for data.    You can enter a query directly using 
the Query command.    The latest queries are listed in the Retrieval menu.    You can also 
predefine queries that you use frequently. The predefined queries are preserved between 
ARCHON sessions.

Use predefined queries
Select a predefined query
Predefine a query
Modify a predefined query
Retrieve an object



 Options Menu

Options Menu commands change the configuration of the user interface. You can specify 
how you prefer to see the icons in the ARCHON window.    You may also reorganize the icons 
in the window.

Change the configuration
Snap icons to a grid
Rearrange icons
Reorganizing the database
Registering ARCHON



 Help Menu

Help Menu commands help using ARCHON. It looks like you have already found out how to 
use these commands.

Get the help index
Get help about commands
Get help about typical command-sequences
Get help about using help
Get information about Shareware and registration
Get information about ARCHON



 Information

To get information about an icon in the window first mark this icon, then choose the 
Information command from the File menu, or press F2, or    click on the F2 field of the 
function bar.



 Dataimport

Use the Dataimport command to read data from DOS-files into objects in the archive.    The 
Dataimport command is available from the File menu, or by pressing F3, or by clicking in the 
F3 field of the function bar or by double-clicking the DOS tool. In the file-specification dialog 
you can specify the element-type of the data to be used. 

In the import dialog you can choose the drive and directory from the appropriate listbox in 
the Files control-group.    In the file listbox you can select multiple files to be imported.    To 
prepare the files for the import add them to the New Objects list in the Import Objects 
control-group.    ARCHON tries to determine the type of each file.    You can also predefine the
filetype from the Format combobox in the Files control-group.    The details of each file in the 
New Objects list can be viewed by selecting an object name in the list.    The future name of 
the object and the filetype may be changed.    You may also enter a description that will be 
indexed in addition to those keywords automatically extracted from the file.    You can add 
files from different directories to the New Objects list.    When you have collected all files to 
be imported start the import operation by clicking the Import button.



 Dataexport

Use the Dataexport command to write data from an object in the archive to a DOS-file.    The 
Dataexport command is available from the File menu, or by pressing F4, or by clicking in the 
F4 field of the function bar.      Or drop the icon of the object on the DOS tool.

Data of all marked objects will be extracted into DOS-files.



 Description

Use the Description command to modify the information for the retrieval of the data.    The 
Description command is available from the File menu, or by pressing F6, or by clicking in the 
F6 field of the function bar. You can change the name of the object and modify a description 
of the object.    The words contained in the name and in the description are included into the 
keywords database and may be used to retrieve the object.



 Exit

Use the Exit command to terminate the ARCHON session.    The command is available from 
the File menu, or by pressing Alt+F4.



 Copy

You may use the Copy command to move data from an object in the archive to the clipboard.
The contents of the clipboard may then be used by another application.    The Copy 
command is only active if an object is marked.

Data is stored in the clipboard in a format according to the element type as specified in the 
profile.



 Paste

If there is data on the clipboard,    you can import its contents.    A new object is created.

The data format is chosen according to the clipboard format of the data.    Clipboard formats 
can only be pasted for which a corresponding data format is defined.    If clipboard data is 
available in multiple formats,    ARCHON chooses the one that holds the most information.



 Delete

Use the Delete command to remove all marked objects from the archive.    The Delete 
command is available from the Edit menu, or by pressing del or by dragging the icons to the 
trash tool.



 Return

Use the Return command to remove marked icons from the window.    The Return command 
is available from the Edit menu or by dragging icons to the archive tool.

Data of the returned icons is still kept in the archive.    To redisplay an icon use the Query 
command.



 Hide

Use the Hide command to remove marked icons from the window.    The Hide command is 
available from the Edit menu, or by pressing F9, or by clicking in the F9 field of the function 
bar.

Hidden icons are kept in a hidden-list.    The Show command redisplays all hidden icons.    To 
get rid of an object-icon without adding it to the hidden-list, drag it to the archive tool or use 
the Return command.



 Show

The Show command redisplays all icons in the hidden-list.    The Show command is available 
from the Edit menu, or by pressing F10, or by clicking in the F10 field of the function bar.    
The command is active only if the hidden-list is not empty.



 Object Methods

Use the commands in the Objects menu to apply the methods you defined in the profile to 
the marked object-icons.    The commands are available from the Objects menu.    Double-
clicking an icon applies the default method.    Dragging an icon to the printer tool applies the
print method.



 Predefined Queries

The Predefined choice of the Retrieval menu presents a submenu with commands for 
predefined queries.    You may choose one of the following:

Select a query
Predefine a new query
Modify an existing query.



 Select Query

Use the Select Query command to select a query from the list of predefined queries.    The 
command is available from the Predefined submenu in the Retrieval menu.



 Define Query

Use the Define Query command to add a new query to the list of predefined queries.    The 
command is available from the Predefined submenu in the Retrieval menu.



 Modify Query

Use the Modify Query command to change a query in the list of predefined queries.    The 
command is available from the Predefined submenu in the Retrieval menu.



 Query

Use the Query command to search for data in the archive.    The command is available from 
the Retrieval menu, or by pressing F7, or by clicking in the F7 field of the function bar or by 
double-clicking the archive tool.

In the object retrieval dialog you can enter keywords in the Query expression field.    These 
keywords are looked for in the retrieval database when you click on the Search button.    A 
report next to the Search button shows you how many objects have been found that match 
the given expression.

The names of these objects are filled into the Objectpool listbox. Select those objects you 
really need by selecting them in the Objectpool and adding them to the Objectselection 
listbox using the Add button.    If you decide that an object in the Objectselection is not one 
that you need you can move it back by clicking the Back button.

You can search for additional objects by changing the Query expression.    When you click the
Search button again the Objectpool listbox will be emptied and filled with objects according 
to the new query.    Objects that you allready have moved to the Objectselection will remain 
there and you can append further objects from the new query.

You can select any object in one of the listboxes and then click on the Show Keywords 
button.    Archon will show you the list of all keywords attached to this object.    This gives you
an additional cue to decide if this object is of interest.



 Configuration

The Configure choice of the Options menu presents a submenu with commands to change 
the configuration of ARCHON to match your taste.    You may choose one of the following:

Function bar: location and size of the function bar
Icons: size and spacing of icons on the ARCHON desktop
Methods: default method and print method
Profile: .INI file entries (methods, data formats)



 Configuration of Function Bar

Use this command to change the appearance of the function bar.    The command is available
from the Configure submenu in the Options menu.
Usually you may want to see it like the function key-block of your keyboard.



 Icon Configuration

This command lets you change the size of the icons in the window.    The grid size for icons 
placed automatically may also be defined.    The command is available from the Configure 
submenu in the Options menu.



 Method Configuration

Use the Method Configuration command to set the default method and the print method.    
The command is available from the Configure submenu in the Options menu.



 Profile

Use the Profile command to customize methods and formats.    The Profile command is 
available from the Configure submenu in the Options menu.

The profile dialog presents information concerning each defined data format.    In the left 
listbox you can choose the format you are interested in.    The first format entry is <Global>.
If the Global format is selected general profile item values can be handled.    The right    
listbox presents a list of all methods or a list of additional profile entries.    To switch between 
these lists click on the Show Items or Show Methods button.

Global profile items
Format specific profile items
Method Definition
Select and modify values
Usage of the buttons



 Snap

Use the Snap command to put all visible icons to a free grid-position.    The Snap command is
available from the Options menu, or by pressing F8, or by clicking in the F8 field of the 
function bar. 



 Rearrange

Use the Rearrange command to sort all icons visible in the window.    The Rearrange 
command is available from the Options menu, or by pressing Shift and F8, or by clicking in 
the F8 field of the function bar while pressing the Shift key.



 Reorganize

Use the Reorganize command to check consistence of the archive and optimize access to 
objects.    The Reorganize command is available from the Options menu.

The Reorganize command detects and eliminates unused entries in the keyword database.



 Register

Use the Register command to order a ARCHON registration number and to enter this 
number.    The Register command is available from the Options menu.

ARCHON is ShareWare.    You can use the Register command to register your copy of 
ARCHON.    In a first dialog box you will be asked for your address.    Your name and address 
will be stored in the database and in the win.ini file.    Later this information will be used to 
verify your registration number.

A second dialog will ask you to actually order an ARCHON registration.    You may print or file 
a completed order form.    The information of the second dialog is not stored in the database.

When the registration form is received by ErgoSoft AG, a temporary registration number will 
immediatly be sent to you.    After processing your registration a permanent registration 
number will be sent to you.    Enter these numbers after clicking the Enter Registration 
Number button.



 Help Index

The Help Index command calls the Microsoft help utility and presents the top index of help-
topics available. The Help Index command is available from the Help menu, or by pressing 
F1, or by clicking in the F1 field of the function bar.



 Help Commands

The Help Commands command presents an index of all available commands.



 Help Procedures

The Help Procedures command presents an index of typical sequences of command usage.



 Help on Help

The Help on Help command calls the explanation on how to use the Microsoft help utility.



 About ARCHON

About ARCHON shows some information about the ARCHON application.





 Function bar

The function bar is a visual copy of the function key block on your keyboard.    Clicking a field
of the function bar is equivalent to pressing the corresponding function key. You can choose 
how your function bar looks using the Functionbar choice in the Options Configure menu.



 Dragging

You can drag an icon by pointing to it with the mouse, pressing the left mouse button, and 
moving the mouse without releasing the button.

To drop the icon release the mouse button.    If you drop the icon over a tool an appropriate 
action will be started.    If you drop the icon anywhere else on the ARCHON desktop the icon 
will be moved there.



 Dropping

You can apply a command to an icon by dragging the icon to a tool-symbol.    Release the 
mouse button when the icon ist over the tool that represents the intended command.



 Keyboard

To select an icon using the keyboard first press and hold down the Control key.    To each icon 
a number will be displayed.    To select or deselect an icon enter its number while holding 
down the Control key.    To give a command from a command menu use the usual keyboard 
accelerators.    You can also activate a tool by holding down the Control key and pressing the 
appropriate character.



 Query Expression

A query is used to find data in the archive. A query expression is composed of a list of 
keywords.

In the keyword, the following ´Wildcard´ characters have a special meaning:
- `*' matches any sequence of characters (zero or more)
- `?' matches any character
- [SET] matches any character in the specified set,
- [!SET] or [^SET] matches any character not in the specified set.
- A set is composed of characters or ranges; a range looks like character hyphen 

character (as in 0-9 or A-Z).
- To suppress the special syntactic significance of any of `[]*?!^-\' in a [..] construct and

match the character exactly, precede it with a `\'.

Keywords may be combined by the logical operators and and or.    A missing operator is 
assumed to be and.    The expression is evaluated left to right, there is no precedence.



 ARCHON

{ahr'-kahn}
In ancient Greek city-states, archons were state magistrates of the highest order.      Athens 
had at first three archons--one each to wield religious, military, and civil powers.    In the 8th 
century BC their tenure was for ten years, but by 683 BC tenure was reduced to one year.    
Soon thereafter, six court magistrates (called themosthetai) were elected, in addition to the 
archons, to record judicial decisions.    The nine positions were the focus of fierce political 
rivalry in the 7th and 6th centuries BC.    After 487 BC the archons were chosen by lot from 
all three social classes, and their importance diminished. Ex-archons became lifetime 
members of the AREOPAGUS.    

Citation from: The Academic American Encyclopedia, online edition, Grolier Electronic 
Publishing, Danbury, CT., 1991.    

(CompuServe:    GO    AAE)

Bibliography: Sealey, Raphael, A History of the Greek City States, 700-338 B.C.
(1976). 



 Predefined Query

ARCHON keeps a list of predefined queries.    You can add frequently used queries to the list 
and modify them by the commands in the Predefined submenu of the Retrieval menu.



 Object

An object represents a file in the archive.    Each object must have a different datatype called
its data format. Data formats are defined in the profile.    The Import and Export commands 
are used to move objects into and out of the archive.

Objects can be located by queries.    Directly accessible objects are visualized by an icon on 
the ARCHON desktop.



 Tool

A tool is an icon on the ARCHON desktop that can be used to start commands.    Commands 
are initiated by dragging an icon to a tool or by double clicking on a tool.



 Method

A method is a user-definable operation to be applied to a data-element in an object. 
Available methods are specified in the profile.    For each method the user can supply 
instructions for applying them to any data format of an object.



 Default Method

The default method is applied to an object when you double-click its icon.    Use the Method 
Configuration command to set the default method.



 Print Method

The print method is applied to an object when you drag its icon to the printer tool.    Use the 
Method Configuration command to set the print method.



 Shareware

ARCHON is Shareware.    This means you may use ARCHON for a reasonable period to find 
out if ARCHON is usefull for you.    After this period you will be invited to register your usage 
of ARCHON.    

Shareware is not Public Domain!    This means copyright laws apply to Shareware in the 
same way as to commercial software.    ErgoSoft AG holds the copyright for ARCHON.    You 
are free to give away unaltered and complete copies of ARCHON but you should register 
after the trial period.



 Global Profile Items

Global profile items represent entries that concern the general behavior of ARCHON.

AutoImportDir: Specification of a full path.    After application of a method ARCHON will 
import all new files found in this directory .

Indexing: Set to 0 or 1.    If Indexing is set to non-zero ARCHON will try to full-text index 
new imported objects.    If set to 0 ARCHON will build the index from the most 
important file specifications..



 Format Specific Profile Items

Format specific profile items are used to customize the methods when they are applied to an
object of the selected format.    

Application: Specification of the application path.    The value of this item can be used as 
$APPLICATION in the method definitions.

Tmpfile: The name of the temporary file.    This name is used in the method definition.    
The value of this item can be used as $TMP in the method definitions.

The Match and Masks item specify how ARCHON can identify the format.
Masks: The Masks item is a list of possible filename masks that match to files of the 

specified format.    Several masks may be separated by ";".
Match: Match defines patterns used to verify that a file is of the specific format.    See 

the documentation for a description of the Match item.



 Method Definition

The method definitions specify how ARCHON will apply a method to an object.    The 
<Global> methods represent a default for each method.    #ID is a reference to the selected 
object. $APPLICATION and $TMP will be replaced by format specific items.
Format specific method definitions can be used when the global definition is not applicable 
to a specific format.    The global definition is used if the format specific one is undefined.
For a definition of the method specification language see the manual.



 Value Selection and Modification

Data Format: Use the Data Format listbox to specify for which format you want to change an
item or a method definition.    The entry <Global> doesn't specify an actual 
format.    Select <Global> if you want to change format unspecific items.

Method: Use the Method listbox to specify which method you want to modify.    If the 
Method listbox is not displayed click on the Show Methods button.

Profile Item: Use the Profile Item listbox to specify which item you want to modify.    If the 
Profile Item listbox is not displayed click on the Show Items button.

Value: In the value field you can change the selected item or method.    If the selected
value is undefined the appropriate default value is displayed.



 Buttons in the Profile Dialog

Delete: The Delete button deletes a data format or a method.    First select the format 
or method to delete in the appropriate listbox and then click on Delete.

Show Items: Show Items switches the right listbox to display the profile items.
Show Methods: Show Methods switches the right listbox to display the methods.
Set to Default: This button deletes format specific methods.    The global value will be 

used instead.    For global methods and all other profile items the default 
provided by ARCHON will be set.

Reset Value: The selected entry is reset to the value when ARCHON was startetd.
Close: Changes in the current value field are ignored and the dialog is terminated.    

Changes made to other values are already in effect.    If you want to revert 
other changes use the Reset Value button.    To revert all changes you can 
terminate ARCHON and leave the Save Configuration checkbox unchecked.

Ok: All changes are accepted and the dialog is closed.





 Getting Data into the Archive

You can put information from a DOS file or from the clipboard into the archive.    Follow these 
steps to import your data:

1a. Select the Import command if you want to import from a DOS file.    In a file selection 
dialog you can specify a list of the names of the files to import.    

1b. Or if you want to paste from the clipboard select the paste command.
2. During the file selection dialog you can choose the format of the data.    If you don't    

specify the data format ARCHON selects an appropriate format.    If ARCHON finds more 
than one possible format you will be asked for the correct one.    
Data pasted from the clipboard is imported automatically in a data format according to 
the format of the clipboard-data.



 Locating Data in the Archive

Occasionally you may wish to locate some data you have put into the archive.    All objects 
you want to access must be represented by an icon on the ARCHON desktop.    Follow these 
steps to access your data:

1a. Select the Query command.

If you frequently use the same queries you can predefine queries using the Predefine Query 
and the Modify Query command.

1b. Or select a predefined query using the Select Query command. 
2. Use the Query Expression to specify how your data can be found. Use the Search button 

to find all documents matching the search expression.
3. From the Objectpool list you can choose the objects you actually want to access.    Use 

the Add button to move the desired objets from the Objectpool to the Objectselection.    
You may view the keywords of any object to ensure that you select the objects you want.
To view the keyword list select the object and click on the Show Keywords button.

4. Click    on the Ok button to display all objects in the Objectselection list on the ARCHON 
desktop.



 Extracting Data from the Archive

There are several places to output data from the archive.    You can write into a DOS file,    or 
you can put the data onto the clipboard or you can apply the print method to it (or any 
method that leaves the data somewhere).    The topic Using Data in the archive describes 
how to apply methods to an object.    To export data to a DOS file or to the clipboard follow 
these steps:

1. Mark the object containing the data to export.    For export to the DOS filessystem you 
can mark a group of objects.

2a. Select the Export command to write a DOS file.    In a file selection dialog you can specify
the filename.    

2b. Or select the Copy command to put data onto the clipboard.



 Using Data in the Archive

In the profile dialog you can specify a list of methods that can be applied to an object.    
These methods are available from the Objects Menu.    There are two special methods: the 
default method and the print method.    These methods are specified by the Method 
Configuration command.    To apply a method follow these steps:

1. Mark the object containing the data to work on.    You can mark a group of objects.
2. Select the appropriate command from the Objects Menu.

To apply the default method double click on the icon or select the icon and press F4, or click 
in the F3 field of the function bar.    To apply the print method drag the icon to the printer 
tool.



 Register ARCHON

The usage of ARCHON during the trial period is free.    When you start ARCHON for the first 
time,    the program will record the date in the new database and in the WIN.INI file.    After 
the trial period you will see a reminder message that you should register.    For registration 
you will run through the following steps:

1. Click on the Register Now button in the reminder message or select Register in the 
Options menu.    You will see a form that asks you for some information about you.    Fill 
in all fields that apply.

2. Click on the Order button to get the order form.    Specify how many copies of ARCHON 
you want to register and how you would like to pay the registration fee.

3a. Write the form to a disk-file by clicking on the file button.    You can send this file by e-
mail or print it and proceed the same way as step 3b. E-mail addresses are:    
CompuServe ID: 100012,147;    Internet-address: 100012.147@Compuserve.com.

3b. Or click on the print button.    The form will be printed on your printer.    Send the form to 
the indicated address by surface mail or by fax.

4. As soon as possible ErgoSoft will send you a temporary registration number.    Enter this 
number using the Register command in the Options menu and clicking on the Enter 
Register Number button.    This will give you an additional period without reminder.

5. When ErgoSoft has received your money a definitive registration number will be sent to 
you.    Entering this number will disable all reminders.



 Selecting Icons

An icon of an object or a tool may be selected by using the mouse or the keyboard.    All 
selected    icons will be considered as the arguments of the next command.

To select an icon using the mouse just point to the icon and click with the left mouse-button. 
Previous selected icons will be deselcted and this icon will visually be marked as selected.    If
you want to select additional icons you must hold down the Shift key while clicking the 
additional icons.    An alternate method is to click with the right mouse button to select 
additional icons.

To select a group of icons at a time you can press the mouse-button while not pointing to 
any icon and drag the mouse over the icons you want to select.    A rectangle will be drawn 
to indicate which icons will be selected.    When you release the button all icons in the 
rectangle will be selected and previous selections will be removed.    If you pressed the Shift 
key during this operation the new selection will be added to the previous selections.    Using 
the right button has the same effect as pressing the Shift key and using the left button.

To select an icon using the keyboard press and hold down the Control key.    All icons now 
have a number faded in.    While holding the Control key enter the number of the icon you 
want to select and then release the Control key.    The new selection is added to previous 
selections.    Select the icon again to remove its selection.





Configuring ARCHON

When you run Archon for the first time, it will present the initial configuration screen for 
setting up its database. Later, you can change the Archon configuration by using the menu 
OPTIONS-CONFIGURE
This menu item has a submenu with the following functions:
- Functionbar

Controls the type and position of the function-bar, if any.
- Icons

Controls positioning and look of icons
- Methods

Setup of method used when dragging icon(s) to the printer or double-clicking an icon
- Profile

Lets you define and change new or existing file formats

About file formats
Archon can handle a virtually unlimited number of file formats. Many popular formats have 
built-in upport, but you can add your own formats by supplying the following information:
- Format name used within Archon. Examples: WinWord, CorelDraw.
- Application used for editing, viewing and printing the file. If you get an application execution error 

when you try to edit a file, you can use this entry to tell Archon exactly where the program is.
Examples: WINWORD, Z:\WIN\CORELDRW

- Tmpfile defines the name of the temporary file that is created when an object is edited, viewed or 
printed.

- Masks indicates files of the given type. Examples: *.DOC;*.DOT and *.CDR. A Masks entry is 
simply a sequence of file name patterns, separated by semicolons. 
Examples: *.DO?;*.TXT

*.XLS;*.XLC;*.XLS;*.XLM;*.XLW or simpler
*.XL?

- Match patterns are patterns and actions of the Archon indexer macro language. Defining the match 
entry properly enables automatic format detection and full text indexing of user defined file formats. 
Creating a match string with full text indexing for an new file format requires programming 
experience. We are happy to help you with this.

To give you an idea, here is the match string for the Windows Write file format:

Warning: extremely technical stuff ahead!

B0=$31; Format check: Byte at offset 0 must be $31
B1=$BE; Format check: Byte at offset 1 must be $BE
S=$E; Indexer: Seek to offset $E
LD@; Load Double word into register @
M@-$80; Subtract $80 from register @
S=$80; Seek to offset $80 
PN; Create full text index of the next N bytes, N=value of Register @

Format detection: When a file is imported, it´s type is matched to one of the know data types:
All filetypes where one of the patterns in Masks matches the filename, will test the files´s contents 
with the patterns in Match. If more than one file format satisfies both conditions, the user has to 
select the proper file format from a list box, but this is very rare. 





The Basic Idea behind ARCHON

How does it work?
Archon stores files in one or more database files and records the exact location of every file 
in a central index. Database files can reside on harddisks, network drives, or removable 
media. Usage of these files is managed automatically by moving rarely used files down the 
storage hierarchy and finally to removable media. When one of these files is accessed again,
Archon requests the corresponding disk and moves the file back to the hard disk. This way, 
you have virtually unlimited storage 
capactiy.

How does Archon help me find my data?
When a file is moved into the Archon storage system keywords are automatically collected 
from the file name, file contents and an optional description. The file may be retrieved at 
any time by entering matching keywords. 

How can Archon extract keywords from different files?
Archon "knows" a great variety of file formats. It uses this knowledge for decoding the 
internal file structure and for extracting textual information. The knowledge base is growing 
rapidly. Currently, it covers formats written by 64 widely used applications, including 
WinWord, MS-Word, WordPerfect, Excel, Lotus, Symphony, CorelDraw and Pagemaker. 
Experienced users may even expand the knowledge base themselves, by adding their own 
formats.

What's the difference between Lotus Magellan and Archon?
- Archon is Windows-based while Magellan is a DOS application.
- Archon manages all the storage you want, automatically. It will offload files to removable media, 

effectively treating them as an extension of your fixed disks.
Magellan compresses and indexes files on your hard disks only, it will not offload to removable 
media.

- Archon users can add their own formats, complete with automatic indexing using our 'Indexer macro 
language'.

What equipment do I need to run Archon?
ARCHON requires Windows 3.0 or 3.1 in standard or enhanced mode, a floppy drive, 2MB 
RAM, and at least 1MB free harddisk space for its index files. Archon will use any storage 
device accessible as a DOS device. This includes network drives as well as removable optical
or magnetic disks.




